Setup Openwrt Xiaomi AX3200 BR01 11-2021 Redmi AX6S

Today i got the openwrt Firmware to run on my new xiaomi ax3200 Router, the Problem is that the Default Firmware open a Upload-Channels to “api.wifimi.com”

Many online wiki told that its impossible to flash the BR01 Version after Production Date 09.21

To flash you need a Serial UART to USB Adaptor and 4 Pin-Lab Cables connected to the Mainboard from bottom without open the Case!!

Remark: Plug Router-Pin-RX to TX at the UART Adapter and Router TX to RX-UART (Crossover!!!) Voltage + is 3,3 Volts!! not 5Volts!!

here some Pictures https://github.com/mikeeq/xiaomi_ax3200_openwrt#uart-flash

REMARK the Pins from bottom must be seen MIRRORED!!!

Open an Linux Terminal and run as User “cu -l /dev/ttyUSB0 -s 115200” after this boot the Router by Power on and Press and hold the little RESET Button a Menu should by seen of UBoot Bootloader select last option..

On the PC create /tmp/tftp and place there this file, rename “*.bin” it to “C0A81F64.img”

https://downloads.openwrt.org/releases/22.03.0/targets/mediatek/mt7622/openwrt-22.03.0-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-sysupgrade.bin

Connect PC to LAN on Router, SET PC IP to “192.168.31.100”

on a second console start the local TFTP Server to upload the File to the Router:

Command:

dnsmasq –no-daemon -i eth0 –dhcp-range=192.168.31.1,192.168.31.99 –enable-tftp –tftp-root=/tmp/tftp –dhcp-boot=C0A81F64.img -p0 -K –log-dhcp –bootp-dynamic

on the Terminal of the Router start “tftpboot” this pulls the openwrt Firmware!

wait..if boot stops press Enter to see the root login, change to /tmp and download again here:

wget https://downloads.openwrt.org/releases/22.03.0/targets/mediatek/mt7622/openwrt-22.03.0-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-sysupgrade.bin

now do sysupgrade by:

sysupgrade openwrt-22.03.0-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-sysupgrade.bin

if ok the Router reboots automaticly.. NOW check that the Router run into the OPENWRT on the UBOOT MENU!

NVRAM Command to modify the UBOOT-NVRAM do not exist at the openwrt-image , my openwrt boot into the 3rd entry of uboot named xiaoo…

If not working re-power the Router into uboot mode, select boot into first firmware.

Its possible that you must openwrt to be default firmware:

at openwrt:

fw_setenv boot_fw1 “run boot_rd_img;bootm”

Check flag-firmware-settings with “fw_printenv” to:

this are my settings..


boot_wait=on
bootargs=console=ttyS0,115200n1 loglevel=8 swiotlb=512 rootfstype=squashfs firmware=0
bootcmd=bootxq
bootdelay=5
bootmenu_0=1. Load firmware 0 and bootup.=run boot_fw0
bootmenu_1=2. Load firmware 1 and bootup.=run boot_fw1
bootmenu_2=3. Load firmware selected by X.... and bootup.=run boot_auto
...
flag_boot_rootfs=0
flag_boot_success=1
flag_boot_type=2
flag_last_success=0
flag_ota_reboot=0
flag_try_sys1_failed=0
flag_try_sys2_failed=0

Rollback to Stock Firmware should be easy by Recovery Mode. Only if the uboot Loader is damaged then you must be a Expert!

I tested NOT RESET of WRT to Factory by LUCI, cause iam happy that the Box runs..

5GHz Limit of the Chip is 36-48 Channel over 48 no Signal!

If uboot Menu fails or other things TRY ALL AGAIN!

 

Design copyright www.linuxonlinehelp.com - Linux PC & Server Support